Author Topic: Help with Smoothing Groups  (Read 1112 times)

0 Members and 1 Guest are viewing this topic.

April 27, 2018, 06:50:37 PM
Read 1112 times

JFJohnny5

  • *
  • Information
  • Newbie
  • Posts: 1
    • View Profile
I am knocking my head against the wall trying to figure this out. This should be super simple, but something isn't working right. I'm working on a simple mod to make some custom art. I modeled the frame and the canvas. I'm able to apply the custom texture image to the canvas no problem. I'm trying to use the default texture for recoloring ingame for the frame. I have it UV mapped correctly so that the recolor works. The problem I'm having is that it's rendering the geometry as being one big smooth surface. It's ignoring the smoothing groups that should show the hard edges. Look in these two pictures.

You can see how it should look based on the frame from the base game (left). You can see how mine is being rendered as though the edges are curved, not sharp (right).
https://www.dropbox.com/s/tctei3v3cminadz/Smoothing%20Groups.JPG


Here is the model in 3DS Max. You can see the sharp edges here; indicators that I have each set of faces set to its own smoothing group.
https://www.dropbox.com/s/10riycbb2kzz3k4/Smoothing%20Groups2.JPG


I'm really baffled. This is pretty basic stuff, but its like Software Inc is ignoring the smoothing groups. Ideas?

June 05, 2018, 08:50:46 PM
Reply #1

mistergreen

  • *
  • Information
  • Member
  • Posts: 5
    • View Profile
In blender (edit mode) setting edges to sharp fixes my shading problems ingame. If you look at my desk with a small curve, the curve is shaded flat and smooth. https://steamcommunity.com/sharedfiles/filedetails/?id=1356575743

I am not sure how shading groups in 3ds max work so im sorry if im not understanding your problem.
« Last Edit: June 05, 2018, 08:53:29 PM by mistergreen »