Author Topic: [FIXED] trouble updating my mod  (Read 3954 times)

0 Members and 1 Guest are viewing this topic.

June 09, 2017, 08:41:47 PM
Read 3954 times

Kauvii

  • *
  • Information
  • Member
  • Posts: 11
    • View Profile
So I have a private steam workshop mod that I try to update. Whenever I press upload, the game gets to the point where is says it's uploading the mod, but then stops. It comes up with an error saying that the update status is invalid. I don't have any clue why this happens, as the first time I tried uploading my mod it worked fine. Could someone explain to me why this happens?
« Last Edit: August 30, 2017, 03:11:35 PM by Kauvii »

June 11, 2017, 11:37:41 PM
Reply #1

pokmon987

  • *
  • Information
  • Member
  • Posts: 105
  • Misk Creator and "Lead" for The Hybrid Project
    • View Profile
What files do you have in the folder? And file types?

June 12, 2017, 08:26:00 PM
Reply #2

Kauvii

  • *
  • Information
  • Member
  • Posts: 11
    • View Profile
C:\Program Files (x86)\Steam\steamapps\common\Software Inc\Mods is where I have my mod's folder. Inside my mod's folder, I have three other folders, Thumbnail.png and TypeInfo.txt. My three folders are called CompanyTypes, NameGenerators, and SoftwareTypes. Inside of CompanyTypes, I have a .xml file. Same goes for SoftwareTypes. In NameGenerators, I have a .txt file.

Whenever I uploaded my mod the first time, everything went correctly. This second time, I changed a bit of the code in SoftwareTypes and added the Thumbnail.png file (to add an icon to my mod in the workshop)

Thanks for helping, I'm new somewhat new to modding and coding.

June 14, 2017, 10:50:05 AM
Reply #3

khornel

  • Dev
  • *****
  • Information
  • Member
  • Administrator
  • Posts: 369
    • View Profile
    • Software Inc
Have you agreed to the Steam Workshop EULA? It pops up the first time you upload, but it will also appear on top of your mod, if you view it in the workshop while you are signed in to Steam.

June 14, 2017, 06:37:26 PM
Reply #4

Kauvii

  • *
  • Information
  • Member
  • Posts: 11
    • View Profile
Steam says I accepted it back on February 12th, so that's not the issue.

I went to my workshop page to delete the mod when I realized I actually had two copies of the mod, one that was the mod I originally uploaded and the other one being a mod without a name and a file size of 0.0 MB. I deleted both versions and tried uploading my mod again with no avail. It recreated the phantom mod without a name and a download size of 0.0.

Could a coding error be a factor into why this is happening? ??? And, just in case this is important, I'm running the testing branch of Software Inc.

EDIT: I put a picture here but it didn't work so I'll just link it: http://imgbomb.com/a/2889/
« Last Edit: June 14, 2017, 06:39:30 PM by Kauvii »

June 14, 2017, 09:06:47 PM
Reply #5

khornel

  • Dev
  • *****
  • Information
  • Member
  • Administrator
  • Posts: 369
    • View Profile
    • Software Inc
Could you try uploading again and then copy the output of the log file? It will detail the events of the upload to Steam and it might show where things are going wrong. Can you verify that the "pubID.txt" file is in the root directory of your mod? If you've downloaded your own mod from Steam, please unsubscribe again, as that could overwrite the correct version of the mod.

June 15, 2017, 02:59:05 AM
Reply #6

Kauvii

  • *
  • Information
  • Member
  • Posts: 11
    • View Profile
Here's output_log.txt:

Initialize engine version: 5.5.3p3 (3ff9bc5a03ff)
GfxDevice: creating device client; threaded=1
Direct3D:
    Version:  Direct3D 11.0 [level 11.0]
    Renderer: NVIDIA GeForce GTX 660 (ID=0x11c0)
    Vendor:   NVIDIA
    VRAM:     1989 MB
    Driver:   21.21.13.7866
Begin MonoManager ReloadAssembly
Platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Software Inc\Software Inc_Data\Managed\UnityEngine.dll (this message is harmless)
Loading C:\Program Files (x86)\Steam\steamapps\common\Software Inc\Software Inc_Data\Managed\UnityEngine.dll into Unity Child Domain
Platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Software Inc\Software Inc_Data\Managed\Assembly-CSharp-firstpass.dll (this message is harmless)
Loading C:\Program Files (x86)\Steam\steamapps\common\Software Inc\Software Inc_Data\Managed\Assembly-CSharp-firstpass.dll into Unity Child Domain
Platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Software Inc\Software Inc_Data\Managed\Assembly-CSharp.dll (this message is harmless)
Loading C:\Program Files (x86)\Steam\steamapps\common\Software Inc\Software Inc_Data\Managed\Assembly-CSharp.dll into Unity Child Domain
Platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Software Inc\Software Inc_Data\Managed\UnityEngine.UI.dll (this message is harmless)
Loading C:\Program Files (x86)\Steam\steamapps\common\Software Inc\Software Inc_Data\Managed\UnityEngine.UI.dll into Unity Child Domain
Platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Software Inc\Software Inc_Data\Managed\UnityEngine.Networking.dll (this message is harmless)
Loading C:\Program Files (x86)\Steam\steamapps\common\Software Inc\Software Inc_Data\Managed\UnityEngine.Networking.dll into Unity Child Domain
Platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Software Inc\Software Inc_Data\Managed\UnityEngine.PlaymodeTestsRunner.dll (this message is harmless)
Loading C:\Program Files (x86)\Steam\steamapps\common\Software Inc\Software Inc_Data\Managed\UnityEngine.PlaymodeTestsRunner.dll into Unity Child Domain
Platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Software Inc\Software Inc_Data\Managed\DOTween.dll (this message is harmless)
Loading C:\Program Files (x86)\Steam\steamapps\common\Software Inc\Software Inc_Data\Managed\DOTween.dll into Unity Child Domain
Platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Software Inc\Software Inc_Data\Managed\DOTween43.dll (this message is harmless)
Loading C:\Program Files (x86)\Steam\steamapps\common\Software Inc\Software Inc_Data\Managed\DOTween43.dll into Unity Child Domain
Platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Software Inc\Software Inc_Data\Managed\DOTween46.dll (this message is harmless)
Loading C:\Program Files (x86)\Steam\steamapps\common\Software Inc\Software Inc_Data\Managed\DOTween46.dll into Unity Child Domain
Platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Software Inc\Software Inc_Data\Managed\DOTween50.dll (this message is harmless)
Loading C:\Program Files (x86)\Steam\steamapps\common\Software Inc\Software Inc_Data\Managed\DOTween50.dll into Unity Child Domain
Platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Software Inc\Software Inc_Data\Managed\SSAA.dll (this message is harmless)
Loading C:\Program Files (x86)\Steam\steamapps\common\Software Inc\Software Inc_Data\Managed\SSAA.dll into Unity Child Domain
- Completed reload, in  0.020 seconds
Platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Software Inc\Software Inc_Data\Managed\System.Core.dll (this message is harmless)
Platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Software Inc\Software Inc_Data\Managed\System.dll (this message is harmless)
<RI> Initializing input.

<RI> Input initialized.

desktop: 1600x900 60Hz; virtual: 1600x900 at 0,0
<RI> Initialized touch support.

UnloadTime: 0.910232 ms
Loading Random Name Generators
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

Loading Sentence Generators
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

Loading Software Types
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

Loading Company Types
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

Loading Companies
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

Loading Events
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

Loading Scenarios
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

Data load time: 0.04096365
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

Software Inc. Alpha Steam 9.8.2, WindowsPlayerx64
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

Starting Steam workshop item upload for item: 947095714
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

Setting title: Web Browser Mod
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

Setting content folder: C:\Program Files (x86)\Steam\steamapps\common\Software Inc\Mods\Web Browser Mod
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

Setting tags: Mod, Software types, AI companies
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

Setting thumbnail C:\Program Files (x86)\Steam\steamapps\common\Software Inc\Mods\Web Browser Mod\Thumbnail.png
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

Submitting to Steam and registering callback
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

Object reference not set to an instance of an object


It seemed it stopped while trying to set / after setting the thumbnail, but I'm not quite sure. Anyways, "pubID.txt" is inside of C:\Program Files (x86)\Steam\steamapps\common\Software Inc\Mods\Web Browser Mod, and I'm not subscribed to my mod from Steam.

June 15, 2017, 12:47:40 PM
Reply #7

khornel

  • Dev
  • *****
  • Information
  • Member
  • Administrator
  • Posts: 369
    • View Profile
    • Software Inc
I know now where the error is happening, but the error isn't documented anywhere in the Steam API, so I have no idea why it's happening. I've added an extra error message in the next patch that says "Update handle invalid", it might help narrow in on the problem, if it is shown. It should release later today. Meanwhile, make sure you haven't set any settings in Steam that would prevent the upload, you could try doing it on another computer, if possible.

June 16, 2017, 04:59:12 AM
Reply #8

Kauvii

  • *
  • Information
  • Member
  • Posts: 11
    • View Profile
I get a message saying the game has detected an error when I try to upload it now. It asks me if I would want to contact you, the developer. If I press no, it gives me the same message as before, while if I press see error, it gives me another window showing weird syntax that I don't understand (as my coding capabilities go as far as modding this one game :L) I can't try uploading it on a different computer as of right now. I would check my Steam settings but I'm getting kind of tired so I'm gonna head off to bed. I'll post again in the morning.

June 16, 2017, 08:48:23 PM
Reply #9

Kauvii

  • *
  • Information
  • Member
  • Posts: 11
    • View Profile
Here are some images of the error windows.

http://imgbomb.com/a/2891/

The first image is what happens when it stops uploading. If I press no, it comes up with the second image. If I press see error it gives me the third image. Hopefully, you can find something useful in the error window. The fourth, fifth, and sixth images is what it looks like after it fails to upload. (Oh, and when I start up my game again and press the workshop button where you upload/update mods, it has no name instead of having the name Web Browser Mod)

Thank you for helping me with this issue. :)

July 19, 2017, 06:47:36 PM
Reply #10

Kauvii

  • *
  • Information
  • Member
  • Posts: 11
    • View Profile
I finally realized what has happened, my pubID file must've been deleted when I was trying to fix it.

This Steam guide is my savior: http://steamcommunity.com/sharedfiles/filedetails/?id=859735046

Thanks Kenneth!

Edit: Nevermind, the game keeps deleting the pubID text file when the error message pops up. Also, the "update status invalid" could've been because of something that I was doing, possibly not the actual error. If I enter in anything in the "briefly write what has changed" box, I get a different error: K_EResultFileNotFound

Someone help, I really want to get back in modding.
« Last Edit: August 17, 2017, 04:10:02 AM by Kauvii »

August 16, 2017, 01:37:28 PM
Reply #11

Kauvii

  • *
  • Information
  • Member
  • Posts: 11
    • View Profile
I just tried to upload my mod again, no pubID, it gave me two errors: K_EResultLimitExceeded and update status invalid.

Could someone explain to me what K_EResultLimitExceeded and K_EResultFileNotFound mean?
« Last Edit: August 17, 2017, 04:09:21 AM by Kauvii »

August 17, 2017, 04:28:26 AM
Reply #12

Kauvii

  • *
  • Information
  • Member
  • Posts: 11
    • View Profile
Agh, I just had one of my buddies (-Flame-, check out his mod! #notsponsored)  help me out with it and the answer was simple: my thumbnail image was too big. Thank you all for helping, and sorry for possibly wasting your time.

...

(I feel really stupid)
« Last Edit: August 29, 2017, 03:45:23 PM by Kauvii »